10 years ago[package] update gpsd to 2.94, add config, init and hotplug scripts, patch from Roberto Riggio
florian []
[package] update gpsd to 2.94, add config, init and hotplug scripts, patch from Roberto Riggio

git-svn-id: svn://svn.openwrt.org/openwrt/packages@22447 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[package] move cd option to proper place, patch from Stefan Bethke.
florian []
[package] move cd option to proper place, patch from Stefan Bethke.

git-svn-id: svn://svn.openwrt.org/openwrt/packages@22446 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[package] add an openvpn-devel package, patch from Gert Doering
florian []
[package] add an openvpn-devel package, patch from Gert Doering

For now, this package uses the symlinked to ../openvpn/files scripts

git-svn-id: svn://svn.openwrt.org/openwrt/packages@22445 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[package] pure-ftpd: add TLS variant (#7658)
florian []
[package] pure-ftpd: add TLS variant (#7658)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@22440 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[package] pure-ftpd: add init script supporting all options (#7659)
florian []
[package] pure-ftpd: add init script supporting all options (#7659)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@22439 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[package] add axel (#7636)
florian []
[package] add axel (#7636)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@22434 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[package] add credis, C library for communicating with Redis servers (#7535)
florian []
[package] add credis, C library for communicating with Redis servers (#7535)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@22433 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[package] p910nd: add IPv6 support (#7646)
florian []
[package] p910nd: add IPv6 support (#7646)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@22432 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[package] tinyproxy: fix creation of pid and log (#7641)
florian []
[package] tinyproxy: fix creation of pid and log (#7641)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@22431 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[package] add mount.ntfs-3.g
florian []
[package] add mount.ntfs-3.g

This patch defines new ntfs-3g package mount.ntfs-3g. The package helps to
add ntfs hotplug mount support for block-hotplug package. Please dont forget
to enable mount helper support in Busybox.

Signed-off-by: Zintis Petersons <zintis.petersons@abcsolutions.lv>

git-svn-id: svn://svn.openwrt.org/openwrt/packages@22430 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[package] add vblade
florian []
[package] add vblade

This is a package for the vblade tool, which exports disks over the
aoe protocol. We already have the aoetools for connecting to them.

Signed-off-by: Kyle Anderson <kyle@xkyle.com>

git-svn-id: svn://svn.openwrt.org/openwrt/packages@22429 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[package] update fowsr to 20100718
florian []
[package] update fowsr to 20100718

changed name of cache file to '/var/fowsr.dat'
- added CWS_print_decoded_data() method
- added debug print outs as command line options
- added patch for checking valid fixed block data (thanks Timo Koivunen!)
- added XML-format output file
- added pywws format table
- added CWS_write_byte() method
- added CWS_write_block() method
- added ws format definitions for unit settings
- added ws format definitions for unit display settings
- added ws format definitions for unit alarm settings

Signed-off-by: Arne-Jørgen Auberg arne.jorgen.auberg@gmail.com

git-svn-id: svn://svn.openwrt.org/openwrt/packages@22428 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[package] update xtables-addons to 1.24, add rawpost and rawnat modules, patch from Ashok Rao
florian []
[package] update xtables-addons to 1.24, add rawpost and rawnat modules, patch from Ashok Rao

git-svn-id: svn://svn.openwrt.org/openwrt/packages@22427 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[package] add missing libid3tag dependency to mpd, patch from Benjamin Cama
florian []
[package] add missing libid3tag dependency to mpd, patch from Benjamin Cama

git-svn-id: svn://svn.openwrt.org/openwrt/packages@22426 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[package] update squid to 2.7STABLE9, thanks to Tomasz Mon
florian []
[package] update squid to 2.7STABLE9, thanks to Tomasz Mon

git-svn-id: svn://svn.openwrt.org/openwrt/packages@22420 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] multiwan: Changed route acquistion to grab everything except default routes.
craigc []
[packages] multiwan: Changed route acquistion to grab everything except default routes.


git-svn-id: svn://svn.openwrt.org/openwrt/packages@22415 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] samba3: make security=share the default, user security is unsuitable due to missing user management capabilities on OpenWrt
jow []
[packages] samba3: make security=share the default, user security is unsuitable due to missing user management capabilities on OpenWrt


git-svn-id: svn://svn.openwrt.org/openwrt/packages@22410 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[package] fix netatalk init script (#7669)
florian []
[package] fix netatalk init script (#7669)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@22400 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[package] update sqlite3 to 3.7.0 (#7668)
florian []
[package] update sqlite3 to 3.7.0 (#7668)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@22399 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] dovecot: update to 1.2.13
swalker []
[packages] dovecot: update to 1.2.13


git-svn-id: svn://svn.openwrt.org/openwrt/packages@22395 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] httping: update to 1.4.4
swalker []
[packages] httping: update to 1.4.4


git-svn-id: svn://svn.openwrt.org/openwrt/packages@22392 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years agopackages/net/bmxd: use stable branches/bmxd-0.3.x (instead of upcoming, unstable, and incompatible trunk/bmxd v0.4)
axel []
packages/net/bmxd: use stable branches/bmxd-0.3.x (instead of upcoming, unstable, and incompatible trunk/bmxd v0.4)
bmxd-0.3.x is fully compatible to former trunk/batman-experimental


git-svn-id: svn://svn.openwrt.org/openwrt/packages@22389 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[package] update mjpg-streamer to r94 (#7491)
florian []
[package] update mjpg-streamer to r94 (#7491)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@22384 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[package] uclibc++: parallel build fix
florian []
[package] uclibc++: parallel build fix

git-svn-id: svn://svn.openwrt.org/openwrt/packages@22381 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] i2c-tools: Package also the python bindings
claudio []
[packages] i2c-tools: Package also the python bindings


git-svn-id: svn://svn.openwrt.org/openwrt/packages@22376 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] cwiid: Package also the python bindings
claudio []
[packages] cwiid: Package also the python bindings


git-svn-id: svn://svn.openwrt.org/openwrt/packages@22375 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] add devmem2
claudio []
[packages] add devmem2


git-svn-id: svn://svn.openwrt.org/openwrt/packages@22369 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] diffutils: update to 3.0, use PKG_INSTALL, handle the busybox diff applet on preinst and postrm, cleanup
swalker []
[packages] diffutils: update to 3.0, use PKG_INSTALL, handle the busybox diff applet on preinst and postrm, cleanup


git-svn-id: svn://svn.openwrt.org/openwrt/packages@22354 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] tmux: update to 1.3 (#7642, thanks Zuljin), use PKG_INSTALL, cleanup
swalker []
[packages] tmux: update to 1.3 (#7642, thanks Zuljin), use PKG_INSTALL, cleanup


git-svn-id: svn://svn.openwrt.org/openwrt/packages@22346 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] vpzone: add missing kmod-tun dependency
swalker []
[packages] vpzone: add missing kmod-tun dependency


git-svn-id: svn://svn.openwrt.org/openwrt/packages@22343 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] c-ares: update to 1.7.3
swalker []
[packages] c-ares: update to 1.7.3


git-svn-id: svn://svn.openwrt.org/openwrt/packages@22342 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] apr: update to 1.4.2
swalker []
[packages] apr: update to 1.4.2


git-svn-id: svn://svn.openwrt.org/openwrt/packages@22341 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] transmission: update to 2.03
obsy []
[packages] transmission: update to 2.03

git-svn-id: svn://svn.openwrt.org/openwrt/packages@22328 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[package] fix inverted libcurl/curl descriptions (#7648)
florian []
[package] fix inverted libcurl/curl descriptions (#7648)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@22322 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] net/freeswitch: bump package version number from previos changes
cshore []
[packages] net/freeswitch: bump package version number from previos changes

git-svn-id: svn://svn.openwrt.org/openwrt/packages@22317 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] net/freeswitch: Fixed/enabled mod_fax compilation
cshore []
[packages] net/freeswitch: Fixed/enabled mod_fax compilation

git-svn-id: svn://svn.openwrt.org/openwrt/packages@22316 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] net/freeswitch: Removed dependency on alsa-lib; FreeSWITCH links it's own copy, not the system library
cshore []
[packages] net/freeswitch: Removed dependency on alsa-lib; FreeSWITCH links it's own copy, not the system library

git-svn-id: svn://svn.openwrt.org/openwrt/packages@22315 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] transmission: update to 2.02
obsy []
[packages] transmission: update to 2.02

git-svn-id: svn://svn.openwrt.org/openwrt/packages@22314 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] net/freeswitch: Add back mistakenly removed warning suppression for print/scanf - needed for avr32
cshore []
[packages] net/freeswitch: Add back mistakenly removed warning suppression for print/scanf - needed for avr32

git-svn-id: svn://svn.openwrt.org/openwrt/packages@22313 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] babel: use uci_get_state
kerneis []
[packages] babel: use uci_get_state

Signed-off-by: Gabriel Kerneis <kerneis@pps.jussieu.fr>

git-svn-id: svn://svn.openwrt.org/openwrt/packages@22310 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] ahcpd: apply unreleased upstream patch
kerneis []
[packages] ahcpd: apply unreleased upstream patch

- Tue Jul 20 00:25:27 CEST 2010 Juliusz Chroboczek <jch@pps.jussieu.fr>
* Fix typo -- ignore autoconf prefixes for plen > 64.
- Use uci_get_state instead of invoking uci directly.

Signed-off-by: Gabriel Kerneis <kerneis@pps.jussieu.fr>

git-svn-id: svn://svn.openwrt.org/openwrt/packages@22309 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] net/freeswitch: Removed accidentally committed warning suppresion
cshore []
[packages] net/freeswitch: Removed accidentally committed warning suppresion

git-svn-id: svn://svn.openwrt.org/openwrt/packages@22308 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] net/freeswitch: Fixed compilation error on gcc4.2.x (avr32)
cshore []
[packages] net/freeswitch: Fixed compilation error on gcc4.2.x (avr32)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@22307 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] net/freeswitch: Disabled mod-flite for avr32 and ixp4xx as those target are not supported by flite at the present time.
cshore []
[packages] net/freeswitch: Disabled mod-flite for avr32 and ixp4xx as those target are not supported by flite at the present time.

git-svn-id: svn://svn.openwrt.org/openwrt/packages@22306 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years agoqt4: do not compile parts which require nptl support when no nptl support is available (as uClibc < 0.9.32)
mirko []
qt4: do not compile parts which require nptl support when no nptl support is available (as uClibc < 0.9.32)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@22300 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] liboping: update to 1.4.0, add a noping package for the ncurses app
swalker []
[packages] liboping: update to 1.4.0, add a noping package for the ncurses app


git-svn-id: svn://svn.openwrt.org/openwrt/packages@22291 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] haproxy: update to 1.4.8, fix disabled keyword
swalker []
[packages] haproxy: update to 1.4.8, fix disabled keyword


git-svn-id: svn://svn.openwrt.org/openwrt/packages@22281 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] mtr: update to 0.80
swalker []
[packages] mtr: update to 0.80


git-svn-id: svn://svn.openwrt.org/openwrt/packages@22280 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] lang/python: Fixed duplicate files in python and python-mini packages by remove files in python-mini from python (since python depends on python mini). Also added three new module packages.
cshore []
[packages] lang/python: Fixed duplicate files in python and python-mini packages by remove files in python-mini from python (since python depends on python mini). Also added three new module packages.

git-svn-id: svn://svn.openwrt.org/openwrt/packages@22278 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years agonet/iputils: nuke ipv6 until we get a proper fix
acoul []
net/iputils: nuke ipv6 until we get a proper fix


git-svn-id: svn://svn.openwrt.org/openwrt/packages@22277 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years agoutils/psmisc: fix peekfd issue on mips/big-endian targets, included upstream patch (thanks nico)
acoul []
utils/psmisc: fix peekfd issue on mips/big-endian targets, included upstream patch (thanks nico)


git-svn-id: svn://svn.openwrt.org/openwrt/packages@22276 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years agoutils/psmisc: update psmisc to 22.12
acoul []
utils/psmisc: update psmisc to 22.12


git-svn-id: svn://svn.openwrt.org/openwrt/packages@22272 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years agonet/ethtool: update to 2.6.34
acoul []
net/ethtool: update to 2.6.34


git-svn-id: svn://svn.openwrt.org/openwrt/packages@22271 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] unbound: remove the two files emptied in r22250, install the two files added in r22267
swalker []
[packages] unbound: remove the two files emptied in r22250, install the two files added in r22267


git-svn-id: svn://svn.openwrt.org/openwrt/packages@22270 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] igmpproxy: fix initscript (closes: #7577), bump release number
nico []
[packages] igmpproxy: fix initscript (closes: #7577), bump release number


git-svn-id: svn://svn.openwrt.org/openwrt/packages@22268 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] unbound: add files missed from [22250] (thanks swalker!)
nico []
[packages] unbound: add files missed from [22250] (thanks swalker!)


git-svn-id: svn://svn.openwrt.org/openwrt/packages@22267 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years agopackage libQtXml, add and fix dependencies
mirko []
package libQtXml, add and fix dependencies

git-svn-id: svn://svn.openwrt.org/openwrt/packages@22265 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years agocopy over qt4 host tools (qmake, moc, rcc, uic) into staging_dir_host
mirko []
copy over qt4 host tools (qmake, moc, rcc, uic) into staging_dir_host

git-svn-id: svn://svn.openwrt.org/openwrt/packages@22264 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years agodo not compile in a different way depending on conditional dependencies, as this fails in some situations and the saved build time isn't worth the maintanance
mirko []
do not compile in a different way depending on conditional dependencies, as this fails in some situations and the saved build time isn't worth the maintanance

git-svn-id: svn://svn.openwrt.org/openwrt/packages@22263 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years agoqt4: avoiding the use of member variable <defname> of struct <__res_state>, as it's disabled in uclibc, bloated and deprecated anyway
mirko []
qt4: avoiding the use of member variable <defname> of struct <__res_state>, as it's disabled in uclibc, bloated and deprecated anyway
<dnsrch[i]> should contain the domain name(s) - however more verification is needed, whether <dnsrch[i]> is an appropriate replacement for <defdname>

git-svn-id: svn://svn.openwrt.org/openwrt/packages@22262 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years agoqt4: update to version 4.7.0 beta2
mirko []
qt4: update to version 4.7.0 beta2

git-svn-id: svn://svn.openwrt.org/openwrt/packages@22261 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years agoadd include path, pointing to the actual qt4-source directory, to CFLAGS - otherwise header files in $STAGING_DIR, if any, will be preferred, which might fail in certain circumstances
mirko []
add include path, pointing to the actual qt4-source directory, to CFLAGS - otherwise header files in $STAGING_DIR, if any, will be preferred, which might fail in certain circumstances

git-svn-id: svn://svn.openwrt.org/openwrt/packages@22260 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[package] add ncftp (#7616)
florian []
[package] add ncftp (#7616)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@22255 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] radsecproxy: update to version 1.4
zandbelt []
[packages] radsecproxy: update to version 1.4

git-svn-id: svn://svn.openwrt.org/openwrt/packages@22253 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] unbound: update configuration files (closes: #7633), bump release number
nico []
[packages] unbound: update configuration files (closes: #7633), bump release number


git-svn-id: svn://svn.openwrt.org/openwrt/packages@22250 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] dibbler: fix initscript (closes: #7628), bump release number
nico []
[packages] dibbler: fix initscript (closes: #7628), bump release number


git-svn-id: svn://svn.openwrt.org/openwrt/packages@22245 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years agonet/bird: allow BIRD to support Unique Local Unicast Address (RFC 4193) type IPv6 addresses
acoul []
net/bird: allow BIRD to support Unique Local Unicast Address (RFC 4193) type IPv6 addresses


git-svn-id: svn://svn.openwrt.org/openwrt/packages@22243 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] asterisk-1.4.x: fix build failure on avr32
nico []
[packages] asterisk-1.4.x: fix build failure on avr32


git-svn-id: svn://svn.openwrt.org/openwrt/packages@22237 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] asterisk-1.4.x: refresh patches
nico []
[packages] asterisk-1.4.x: refresh patches


git-svn-id: svn://svn.openwrt.org/openwrt/packages@22236 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] sigscheme: don't build on avr32
nico []
[packages] sigscheme: don't build on avr32

It's not supported on this arch (yet):

./include/private/gcconfig.h:481:5: error: #error "The collector has not been ported to this machine/OS combination."



git-svn-id: svn://svn.openwrt.org/openwrt/packages@22235 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] collectd: fix another build failure on avr32
nico []
[packages] collectd: fix another build failure on avr32

the ted plugin fails on avr32 with the following error:

cc1: warnings being treated as errors
ted.c: In function 'ted_read_value':
ted.c:153: warning: format '%zi' expects type 'signed size_t', but argument 3 has type 'ssize_t'



git-svn-id: svn://svn.openwrt.org/openwrt/packages@22234 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] libtorrent: fix error when linking against libtorrent on arm (closes: #7026)
nico []
[packages] libtorrent: fix error when linking against libtorrent on arm (closes: #7026)


git-svn-id: svn://svn.openwrt.org/openwrt/packages@22233 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] collectd: fix build failure on avr32
nico []
[packages] collectd: fix build failure on avr32


git-svn-id: svn://svn.openwrt.org/openwrt/packages@22232 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] ortp: fix build failure on avr32
nico []
[packages] ortp: fix build failure on avr32


git-svn-id: svn://svn.openwrt.org/openwrt/packages@22231 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] ruby: add dependency on libpthread to libruby, use minor version for library path (closes: #7608)
nico []
[packages] ruby: add dependency on libpthread to libruby, use minor version for library path (closes: #7608)


git-svn-id: svn://svn.openwrt.org/openwrt/packages@22226 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] fswebcam: don't build on 2.4
nico []
[packages] fswebcam: don't build on 2.4

* uses Video 4 Linux 2, only available on 2.6



git-svn-id: svn://svn.openwrt.org/openwrt/packages@22225 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] cwiid: don't build on 2.4, reformat, cleanup
nico []
[packages] cwiid: don't build on 2.4, reformat, cleanup

* use the uinput subsystem, only available on 2.6



git-svn-id: svn://svn.openwrt.org/openwrt/packages@22224 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] gstreamer: fix libgstreamer dependencies not inherited from default (missed from [22220])
nico []
[packages] gstreamer: fix libgstreamer dependencies not inherited from default (missed from [22220])


git-svn-id: svn://svn.openwrt.org/openwrt/packages@22221 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] gstreamer & gst-plugins-*: don't build on 2.4
nico []
[packages] gstreamer & gst-plugins-*: don't build on 2.4

* uses prctl(PR_SET_NAME...) only available on 2.6



git-svn-id: svn://svn.openwrt.org/openwrt/packages@22220 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] iputils: don't build on 2.4
nico []
[packages] iputils: don't build on 2.4

* uses setsockopt(sock, SOL_SOCKET, SO_MARK, ...) only available on 2.6



git-svn-id: svn://svn.openwrt.org/openwrt/packages@22219 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] bind: fix pid file path (#7218)
jow []
[packages] bind: fix pid file path (#7218)


git-svn-id: svn://svn.openwrt.org/openwrt/packages@22217 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] libdlna: fix build failure (closes: #7445)
nico []
[packages] libdlna: fix build failure (closes: #7445)



git-svn-id: svn://svn.openwrt.org/openwrt/packages@22210 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] tinc: fix build on powerpc (closes: #7072), reformat
nico []
[packages] tinc: fix build on powerpc (closes: #7072), reformat


git-svn-id: svn://svn.openwrt.org/openwrt/packages@22208 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] usbip: fix usb.ids location, rename bind_driver(8) to usbip_bind_driver(8)
nunojpg []
[packages] usbip: fix usb.ids location, rename bind_driver(8) to usbip_bind_driver(8)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@22185 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] lftp: update to 4.0.9
swalker []
[packages] lftp: update to 4.0.9


git-svn-id: svn://svn.openwrt.org/openwrt/packages@22184 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] proftpd: update to 1.3.3a
swalker []
[packages] proftpd: update to 1.3.3a


git-svn-id: svn://svn.openwrt.org/openwrt/packages@22183 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] opendchub: update to 0.8.2
swalker []
[packages] opendchub: update to 0.8.2


git-svn-id: svn://svn.openwrt.org/openwrt/packages@22182 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] dash: update to 0.5.6.1, use PKG_INSTALL, cleanup
swalker []
[packages] dash: update to 0.5.6.1, use PKG_INSTALL, cleanup


git-svn-id: svn://svn.openwrt.org/openwrt/packages@22181 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] dovecot: update to 1.2.12
swalker []
[packages] dovecot: update to 1.2.12


git-svn-id: svn://svn.openwrt.org/openwrt/packages@22180 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] subversion: update to 1.6.12
swalker []
[packages] subversion: update to 1.6.12


git-svn-id: svn://svn.openwrt.org/openwrt/packages@22179 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] zile: update to 2.3.18
swalker []
[packages] zile: update to 2.3.18


git-svn-id: svn://svn.openwrt.org/openwrt/packages@22178 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] net/freeswitch: Fixed a build error on avr32 due to pedantic format type checking for printf.
cshore []
[packages] net/freeswitch: Fixed a build error on avr32 due to pedantic format type checking for printf.

git-svn-id: svn://svn.openwrt.org/openwrt/packages@22167 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] freeswitch: update additional downloads used in v1.0.6
nico []
[packages] freeswitch: update additional downloads used in v1.0.6


git-svn-id: svn://svn.openwrt.org/openwrt/packages@22166 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] ddns-scripts:
jow []
[packages] ddns-scripts:
- urlencode exclamation marks (#7607)
- support new token [HTTPAUTH] for unencoded username:password tuples


git-svn-id: svn://svn.openwrt.org/openwrt/packages@22165 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] iperf: update to 2.0.5
swalker []
[packages] iperf: update to 2.0.5


git-svn-id: svn://svn.openwrt.org/openwrt/packages@22164 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] httping: update to 1.4.3
swalker []
[packages] httping: update to 1.4.3


git-svn-id: svn://svn.openwrt.org/openwrt/packages@22163 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] net/freeswitch: Add back patch for mod_sofia logger, which is needed for kirkwood to compile.
cshore []
[packages] net/freeswitch: Add back patch for mod_sofia logger, which is needed for kirkwood to compile.

git-svn-id: svn://svn.openwrt.org/openwrt/packages@22162 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] dibbler: remove obsolete hacks (not linked against uClibc++ anymore)
nico []
[packages] dibbler: remove obsolete hacks (not linked against uClibc++ anymore)


git-svn-id: svn://svn.openwrt.org/openwrt/packages@22161 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] libpng: update to 1.2.44, change InstallDev to install libpng*-config script in $(1) and a symlink in $(2), reformat
nico []
[packages] libpng: update to 1.2.44, change InstallDev to install libpng*-config script in $(1) and a symlink in $(2), reformat


git-svn-id: svn://svn.openwrt.org/openwrt/packages@22160 3c298f89-4303-0410-b956-a3cf2f4a3e73

10 years ago[packages] ntpd: update to 4.2.6p2, add missing conffiles & postinst for ntpd-ssl, reformat
nico []
[packages] ntpd: update to 4.2.6p2, add missing conffiles & postinst for ntpd-ssl, reformat



git-svn-id: svn://svn.openwrt.org/openwrt/packages@22159 3c298f89-4303-0410-b956-a3cf2f4a3e73

comments