[packages] gstreamer & gst-plugins-*: don't build on 2.4
[packages] gstreamer & gst-plugins-*: don't build on 2.4

* uses prctl(PR_SET_NAME...) only available on 2.6



git-svn-id: svn://svn.openwrt.org/openwrt/packages@22220 3c298f89-4303-0410-b956-a3cf2f4a3e73

--- a/multimedia/gst-plugins-base/Makefile
+++ b/multimedia/gst-plugins-base/Makefile
@@ -27,6 +27,7 @@
   SECTION:=multimedia
   TITLE:=GStreamer
   URL:=http://gstreamer.freedesktop.org/
+  DEPENDS:= @!LINUX_2_4
 endef
 
 define Package/gstreamer/description/Default

--- a/multimedia/gst-plugins-good/Makefile
+++ b/multimedia/gst-plugins-good/Makefile
@@ -26,6 +26,7 @@
   SECTION:=multimedia
   TITLE:=GStreamer
   URL:=http://gstreamer.freedesktop.org/
+  DEPENDS:= @!LINUX_2_4
 endef
 
 define Package/gstreamer/description/Default

--- a/multimedia/gst-plugins-ugly/Makefile
+++ b/multimedia/gst-plugins-ugly/Makefile
@@ -27,6 +27,7 @@
   SECTION:=multimedia
   TITLE:=GStreamer
   URL:=http://gstreamer.freedesktop.org/
+  DEPENDS:= @!LINUX_2_4
 endef
 
 define Package/gstreamer/description/Default

--- a/multimedia/gstreamer/Makefile
+++ b/multimedia/gstreamer/Makefile
@@ -25,6 +25,7 @@
   SECTION:=multimedia
   TITLE:=GStreamer
   URL:=http://gstreamer.freedesktop.org/
+  DEPENDS:= @!LINUX_2_4
 endef
 
 define Package/gstreamer/description/Default

comments