[packages] collectd: Fixed error for git users due to use of git describe for version number (which pulls any tags on the git tree for OpenWRT, not collectd as the author intended.
[packages] collectd: Fixed error for git users due to use of git describe for version number (which pulls any tags on the git tree for OpenWRT, not collectd as the author intended.

git-svn-id: svn://svn.openwrt.org/openwrt/packages@24478 3c298f89-4303-0410-b956-a3cf2f4a3e73

--- /dev/null
+++ b/utils/collectd/patches/200-fix-git-describe-error.patch
@@ -1,1 +1,12 @@
+--- a/version-gen.sh
++++ b/version-gen.sh
+@@ -2,7 +2,7 @@
+ 
+ DEFAULT_VERSION="4.10.2.git"
+ 
+-VERSION="`git describe 2> /dev/null | sed -e 's/^collectd-//'`"
++#VERSION="`git describe 2> /dev/null | sed -e 's/^collectd-//'`"
+ 
+ if test -z "$VERSION"; then
+ 	VERSION="$DEFAULT_VERSION"
 

comments