ksymoops: remove package, it has been obsolete and useless for a long time
ksymoops: remove package, it has been obsolete and useless for a long time

Signed-off-by: Felix Fietkau <nbd@openwrt.org>

git-svn-id: svn://svn.openwrt.org/openwrt/packages@44626 3c298f89-4303-0410-b956-a3cf2f4a3e73

file:a/devel/ksymoops/Makefile (deleted)
--- a/devel/ksymoops/Makefile
+++ /dev/null
@@ -1,59 +1,1 @@
-#
-# Copyright (C) 2009 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
 
-include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/kernel.mk
-
-PKG_NAME:=ksymoops
-PKG_VERSION:=2.4.11
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=@KERNEL/linux/utils/kernel/ksymoops/v2.4/
-PKG_MD5SUM:=4a8249e182a5dbc75e566d162e9f3314
-
-PKG_BUILD_DEPENDS:=binutils
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/ksymoops
-  SECTION:=utils
-  CATEGORY:=Utilities
-  DEPENDS:=@mips||mipsel||m68k||i386 +zlib
-  TITLE:=Interpret oops of the kernel
-  URL:=http://www.kernel.org/pub/linux/utils/kernel/ksymoops/v2.4/
-  MENU:=1
-endef
-
-define Package/kexec-tools/description
-endef
-
-define Build/Configure
-endef
-
-TARGET=$(strip $(shell echo $(TARGET_CFLAGS) | cut -d- -f4 | cut -d= -f2))
-
-define Build/Compile
-	$(MAKE) -C $(PKG_BUILD_DIR) \
-		CC="$(TARGET_CC)" \
-		BFD_PREFIX="$(STAGING_DIR)/usr" \
-		DEF_TARGET='\"$(TARGET)\"' \
-		DEF_ARCH='\"$(ARCH)\"' \
-		DEF_MAP='\"$(LINUX_DIR)/System.map\"' \
-		CROSS="$(TARGET_CROSS)" \
-		INSTALL_PREFIX="$(PKG_INSTALL_DIR)" \
-		LDFLAGS="-lz" \
-		all install
-endef
-
-define Package/ksymoops/install
-	$(INSTALL_DIR) $(1)/bin
-	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/bin/$(TARGET_CROSS)ksymoops $(1)/bin/ksymoops
-endef
-
-$(eval $(call BuildPackage,ksymoops))
-

file:a/libs/libugpio/Makefile (deleted)
--- a/libs/libugpio/Makefile
+++ /dev/null
@@ -1,74 +1,1 @@
-#
-# Copyright (C) 2012 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
 
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=libugpio
-PKG_VERSION:=0.0.1
-PKG_RELEASE=$(PKG_SOURCE_VERSION)-1
-
-PKG_SOURCE_PROTO:=git
-PKG_SOURCE_URL:=git://github.com/mhei/libugpio.git
-PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=8235d04096bfa9db594d5df75c5cd634a3bbc39a
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
-
-PKG_INSTALL:=1
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/libugpio
-  SECTION:=libs
-  CATEGORY:=Libraries
-  URL:=https://github.com/mhei/libugpio
-  TITLE:=Library for using sysfs gpio interface from C programs
-  DEPENDS:=@GPIO_SUPPORT
-endef
-
-define Package/libugpio/description
-  libugpio is a library to ease the use of linux kernel's sysfs
-  gpio interface from C programs and/or other libraries.
-endef
-
-define Package/gpioctl-sysfs
-  SECTION:=utils
-  CATEGORY:=Utilities
-  TITLE:=Tool for controlling gpio pins
-  DEPENDS:=+libugpio
-endef
-
-define Package/gpioctl-sysfs/description
-  Tool for controlling gpio pins using the sysfs api provided by the kernel.
-endef
-
-define Build/Configure
-	( cd "$(PKG_BUILD_DIR)"; ./autogen.sh )
-	$(call Build/Configure/Default)
-endef
-
-define Build/InstallDev
-	$(INSTALL_DIR) $(1)/usr/include
-	$(CP) $(PKG_INSTALL_DIR)/usr/include/ugpio $(1)/usr/include/
-	$(INSTALL_DIR) $(1)/usr/lib
-	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libugpio.{so*,a} $(1)/usr/lib/
-	$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
-	$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libugpio.pc $(1)/usr/lib/pkgconfig/
-endef
-
-define Package/libugpio/install
-	$(INSTALL_DIR) $(1)/usr/lib
-	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libugpio.so* $(1)/usr/lib/
-endef
-
-define Package/gpioctl-sysfs/install
-	$(INSTALL_DIR) $(1)/usr/bin
-	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/gpioctl $(1)/usr/bin/
-endef
-
-$(eval $(call BuildPackage,libugpio))
-$(eval $(call BuildPackage,gpioctl-sysfs))
-

--- a/net/vpnc-scripts/Makefile
+++ /dev/null
@@ -1,57 +1,1 @@
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
 
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=vpnc-scripts
-PKG_VERSION:=20120423
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=ftp://ftp.infradead.org/pub/vpnc-scripts/
-PKG_MD5SUM:=3265dc7fe57ae9b4c905961a28699c4c
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/vpnc-scripts
-  SECTION:=net
-  CATEGORY:=Network
-  DEPENDS:=+ip
-  TITLE:=VPN configuration script for vpnc and OpenConnect
-  URL:=http://www.infradead.org/openconnect/vpnc-script.html
-  SUBMENU:=VPN
-endef
-
-define Package/vpnc/vpnc-scripts
-	This package contains the vpnc-script which is used by vpnc
-	and OpenConnect to configure the tunnel interface.
-endef
-
-define Package/vpnc-scripts/conffiles
-/etc/vpnc/connect.d/
-/etc/vpnc/post-connect.d/
-/etc/vpnc/disconnect.d/
-/etc/vpnc/post-connect.d/
-/etc/vpnc/reconnect.d/
-endef
-
-define Build/Compile
-endef
-
-define Package/vpnc-scripts/install
-	$(INSTALL_DIR) $(1)/etc/vpnc
-	$(INSTALL_DIR) $(1)/etc/vpnc/connect.d
-	$(INSTALL_DIR) $(1)/etc/vpnc/post-connect.d
-	$(INSTALL_DIR) $(1)/etc/vpnc/disconnect.d
-	$(INSTALL_DIR) $(1)/etc/vpnc/post-disconnect.d
-	$(INSTALL_DIR) $(1)/etc/vpnc/reconnect.d
-	$(INSTALL_BIN) ./files/etc/vpnc/connect.d/ifstate $(1)/etc/vpnc/connect.d/
-	$(INSTALL_BIN) $(PKG_BUILD_DIR)/vpnc-script $(1)/etc/vpnc/
-endef
-
-$(eval $(call BuildPackage,vpnc-scripts))
-

--- a/net/vpnc-scripts/files/etc/vpnc/connect.d/ifstate
+++ /dev/null
@@ -1,8 +1,1 @@
-if [ -r /etc/openwrt_release ] && [ -n "$OPENWRT_INTERFACE" ]; then
-    uci_set_state network "$OPENWRT_INTERFACE" banner "$CISCO_BANNER"
-    uci_set_state network "$OPENWRT_INTERFACE" ifname "$TUNDEV"
-    [ -n "$INTERNAL_IP4_ADDRESS" ] && uci_set_state network "$OPENWRT_INTERFACE" ipaddr "$INTERNAL_IP4_ADDRESS"
-    [ -n "$INTERNAL_IP6_NETMASK" ] && uci_set_state network "$OPENWRT_INTERFACE" ip6addr "$INTERNAL_IP6_NETMASK"
-    env -i ACTION="ifup" INTERFACE="$OPENWRT_INTERFACE" DEVICE="$TUNDEV" PROTO=openconnect /sbin/hotplug-call "iface"
-fi
 

file:a/net/vpnc/Makefile (deleted)
--- a/net/vpnc/Makefile
+++ /dev/null
@@ -1,62 +1,1 @@
-#
-# Copyright (C) 2006-2012 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
 
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=vpnc
-PKG_VERSION:=0.5.3
-PKG_RELEASE:=3
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.unix-ag.uni-kl.de/~massar/vpnc/
-PKG_MD5SUM:=4378f9551d5b077e1770bbe09995afb3
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/vpnc
-  SECTION:=net
-  CATEGORY:=Network
-  DEPENDS:=+libgpg-error +libgcrypt +kmod-tun +vpnc-scripts
-  TITLE:=VPN client for Cisco EasyVPN
-  URL:=http://www.unix-ag.uni-kl.de/~massar/vpnc/
-  SUBMENU:=VPN
-endef
-
-define Package/vpnc/description
-	A VPN client compatible with Cisco's EasyVPN equipment.
-
-	Supports IPSec (ESP) with Mode Configuration and Xauth.  Supports only
-	shared-secret IPSec authentication with Xauth, AES (256, 192, 128),
-	3DES, 1DES, MD5, SHA1, DH1/2/5 and IP tunneling.
-endef
-
-define Package/vpnc/conffiles
-/etc/vpnc/default.conf
-endef
-
-define Build/Compile
-	$(call Build/Compile/Default, \
-		OFLAGS="$(TARGET_CFLAGS)" \
-		OS="Linux" \
-		STAGING_DIR="$(STAGING_DIR)" \
-		DESTDIR="$(PKG_INSTALL_DIR)" \
-		PREFIX=/usr \
-		all install \
-	)
-endef
-
-define Package/vpnc/install
-	$(INSTALL_DIR) $(1)/usr/sbin
-	$(CP)	$(PKG_INSTALL_DIR)/usr/sbin/vpnc \
-		$(PKG_INSTALL_DIR)/usr/sbin/vpnc-disconnect \
-		$(1)/usr/sbin/
-	$(INSTALL_DIR) $(1)/etc/vpnc
-	$(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/vpnc/default.conf $(1)/etc/vpnc/
-endef
-
-$(eval $(call BuildPackage,vpnc))
-

--- a/net/vpnc/patches/001-cross.patch
+++ /dev/null
@@ -1,30 +1,1 @@
---- a/Makefile
-+++ b/Makefile
-@@ -20,7 +20,7 @@
- # $Id: Makefile 312 2008-06-15 18:09:42Z Joerg Mayer $
- 
- DESTDIR=
--PREFIX=/usr/local
-+PREFIX=/usr
- ETCDIR=/etc/vpnc
- BINDIR=$(PREFIX)/bin
- SBINDIR=$(PREFIX)/sbin
-@@ -51,14 +51,11 @@ RELEASE_VERSION := $(shell cat VERSION)
- #OPENSSLLIBS = -lcrypto
- 
- CC=gcc
--CFLAGS ?= -O3 -g
--CFLAGS += -W -Wall -Wmissing-declarations -Wwrite-strings
--CFLAGS +=  $(shell libgcrypt-config --cflags)
-+CFLAGS += -W -Wall -Wmissing-declarations -Wwrite-strings -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include $(OFLAGS) '-DVERSION="$(shell cat VERSION)"'
- CPPFLAGS += -DVERSION=\"$(VERSION)\" $(OPENSSL_GPL_VIOLATION)
--LDFLAGS ?= -g
--LDFLAGS += $(shell libgcrypt-config --libs) $(OPENSSLLIBS)
-+LDFLAGS = -L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib -lgcrypt -lgpg-error
- 
--ifeq ($(shell uname -s), SunOS)
-+ifeq ($(OS), SunOS)
- LDFLAGS += -lnsl -lresolv -lsocket
- endif
- ifneq (,$(findstring Apple,$(shell $(CC) --version)))
 

--- a/net/vpnc/patches/002-vpn_script.patch
+++ /dev/null
@@ -1,42 +1,1 @@
---- a/vpnc-script.in
-+++ b/vpnc-script.in
-@@ -97,7 +97,7 @@ do_ifconfig() {
- 	fi
- 
- 	# Point to point interface require a netmask of 255.255.255.255 on some systems
--	ifconfig "$TUNDEV" inet "$INTERNAL_IP4_ADDRESS" $ifconfig_syntax_ptp "$INTERNAL_IP4_ADDRESS" netmask 255.255.255.255 mtu ${MTU} up
-+	ifconfig "$TUNDEV" "$INTERNAL_IP4_ADDRESS" $ifconfig_syntax_ptp "$INTERNAL_IP4_ADDRESS" netmask 255.255.255.255 mtu ${MTU} up
- 
- 	if [ -n "$INTERNAL_IP4_NETMASK" ]; then
- 		set_network_route $INTERNAL_IP4_NETADDR $INTERNAL_IP4_NETMASK $INTERNAL_IP4_NETMASKLEN
-@@ -503,6 +503,18 @@ do_disconnect() {
- 	destroy_tun_device
- }
- 
-+start_vpn_nat() {
-+	iptables -A forwarding_rule -o $TUNDEV -j ACCEPT
-+	iptables -A forwarding_rule -i $TUNDEV -j ACCEPT
-+	iptables -t nat -A postrouting_rule -o $TUNDEV -j MASQUERADE
-+}
-+
-+stop_vpn_nat() {
-+	iptables -t nat -D postrouting_rule -o $TUNDEV -j MASQUERADE
-+	iptables -D forwarding_rule -i $TUNDEV -j ACCEPT
-+	iptables -D forwarding_rule -o $TUNDEV -j ACCEPT
-+}
-+
- #### Main
- 
- if [ -z "$reason" ]; then
-@@ -516,8 +528,10 @@ case "$reason" in
- 		;;
- 	connect)
- 		do_connect
-+		start_vpn_nat
- 		;;
- 	disconnect)
-+		stop_vpn_nat
- 		do_disconnect
- 		;;
- 	*)
 

--- a/net/vpnc/patches/003-no_makeman.patch
+++ /dev/null
@@ -1,12 +1,1 @@
---- a/Makefile
-+++ b/Makefile
-@@ -69,7 +69,7 @@ vpnc : $(OBJS) vpnc.o
- 	$(CC) -o $@ $^ $(LDFLAGS)
- 
- vpnc.8 : vpnc.8.template makeman.pl vpnc
--	./makeman.pl
-+	touch vpnc.8
- 
- vpnc-script : vpnc-script.in
- 	sed -e 's,@''PREFIX''@,$(PREFIX),g' $< > $@ && chmod 755 $@
 

file:a/utils/vim/Makefile (deleted)
--- a/utils/vim/Makefile
+++ /dev/null
@@ -1,193 +1,1 @@
-#
-# Copyright (C) 2006-2012 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
 
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=vim
-PKG_VERSION:=7.3
-PKG_RELEASE:=1
-VIMVER:=73
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=ftp://ftp.vim.org/pub/vim/unix/
-PKG_MD5SUM:=5b9510a17074e2b37d8bb38ae09edbf2
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)$(VIMVER)
-PKG_BUILD_PARALLEL:=1
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/vim/Default
-  SECTION:=utils
-  CATEGORY:=Utilities
-  DEPENDS:=+libncurses
-  TITLE:=Vi IMproved - enhanced vi editor
-  URL:=http://www.vim.org/
-  SUBMENU:=Editors
-endef
-
-define Package/vim
-  $(call Package/vim/Default)
-  TITLE+= (Tiny)
-endef
-
-define Package/vim-full
-  $(call Package/vim/Default)
-  TITLE+= (Normal)
-endef
-
-define Package/vim-runtime
-  $(call Package/vim/Default)
-  TITLE+= (runtime files)
-endef
-
-define Package/vim-help
-  $(call Package/vim/Default)
-  TITLE+= (help files)
-endef
-
-define Package/xxd
-  SECTION:=utils
-  CATEGORY:=Utilities
-  TITLE:=make a hexdump or do the reverse
-  URL:=http://www.vim.org/
-endef
-
-define Package/vim-full/conffiles
-/usr/share/vim/vimrc
-endef
-
-define Package/vim/conffiles
-/usr/share/vim/vimrc
-endef
-
-define Package/vim/description
- Vim is an almost compatible version of the UNIX editor Vi.
- (Tiny build)
-endef
-
-define Package/vim-full/description
- Vim is an almost compatible version of the UNIX editor Vi.
- (Normal build)
-endef
-
-define Package/vim-runtime/description
- Vim is an almost compatible version of the UNIX editor Vi.
- (Runtime files)
-endef
-
-define Package/vim-help/description
- Vim is an almost compatible version of the UNIX editor Vi.
- (Help files)
-endef
-
-define Package/xxd/description
- xxd creates a hex dump of a given file or standard input, it can also convert
- a hex dump back to its original binary form.
-endef
-
-CONFIGURE_ARGS += \
-	--disable-gui \
-	--disable-gtktest \
-	--disable-xim \
-	--without-x \
-	--disable-netbeans \
-	--disable-cscope \
-	--disable-gpm \
-	--with-tlib=ncurses
-
-CONFIGURE_VARS += \
-	vim_cv_getcwd_broken=no \
-	vim_cv_memmove_handles_overlap=yes \
-	vim_cv_stat_ignores_slash=yes \
-	vim_cv_tgetent=zero \
-	vim_cv_terminfo=yes \
-	vim_cv_toupper_broken=no \
-	vim_cv_tty_group=root \
-	vim_cv_tty_mode=0620
-
-ifneq ($(CONFIG_PACKAGE_vim),)
-define Build/Compile/vim
-	$(call Build/Configure/Default, \
-		--with-features=tiny \
-		--disable-multibyte \
-	)
-	$(MAKE) -C $(PKG_BUILD_DIR) clean
-	+$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
-		DESTDIR="$(PKG_INSTALL_DIR)" all
-	$(CP) $(PKG_BUILD_DIR)/src/$(PKG_NAME) $(PKG_BUILD_DIR)/vim_tiny
-endef
-endif
-
-ifneq ($(CONFIG_PACKAGE_vim-full),)
-define Build/Compile/vim-full
-	$(call Build/Configure/Default, \
-		--with-features=normal \
-		--enable-multibyte \
-	)
-	$(MAKE) -C $(PKG_BUILD_DIR) clean
-	+$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
-		DESTDIR="$(PKG_INSTALL_DIR)" all
-	$(CP) $(PKG_BUILD_DIR)/src/$(PKG_NAME) $(PKG_BUILD_DIR)/vim_normal
-endef
-endif
-
-ifneq ($(CONFIG_PACKAGE_xxd),)
-define Build/Compile/xxd
-	+$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
-		DESTDIR="$(PKG_INSTALL_DIR)" all
-endef
-endif
-
-define Build/Compile/vim-runtime
-	$(MAKE) -C $(PKG_BUILD_DIR)/src DESTDIR="$(PKG_INSTALL_DIR)" installrtbase
-	(cd $(PKG_INSTALL_DIR) && tar -cf $(PKG_BUILD_DIR)/docs.tar ./usr/share/vim/vim$(VIMVER)/doc)
-	rm -rf $(PKG_INSTALL_DIR)/usr/share/vim/vim$(VIMVER)/doc
-	rm -rf $(PKG_INSTALL_DIR)/usr/man
-endef
-
-define Build/Compile
-$(call Build/Compile/vim)
-$(call Build/Compile/vim-full)
-$(call Build/Compile/vim-runtime)
-$(call Build/Compile/xxd)
-endef
-
-define Package/vim/install
-	$(INSTALL_DIR) $(1)/usr/bin
-	$(INSTALL_BIN) $(PKG_BUILD_DIR)/vim_tiny $(1)/usr/bin/vim
-	$(INSTALL_DIR) $(1)/usr/share/vim
-	$(INSTALL_CONF) ./files/vimrc $(1)/usr/share/vim/
-endef
-
-define Package/vim-full/install
-	$(INSTALL_DIR) $(1)/usr/bin
-	$(INSTALL_BIN) $(PKG_BUILD_DIR)/vim_normal $(1)/usr/bin/vim
-	$(INSTALL_DIR) $(1)/usr/share/vim
-	$(INSTALL_CONF) ./files/vimrc.full $(1)/usr/share/vim/vimrc
-endef
-
-define Package/vim-runtime/install
-	$(CP) $(PKG_INSTALL_DIR)/* $(1)
-	rm -rf $(1)/usr/share/vim/vim$(VIMVER)/doc
-endef
-
-define Package/vim-help/install
-	tar -C $(1) -xf $(PKG_BUILD_DIR)/docs.tar
-endef
-
-define Package/xxd/install
-	$(INSTALL_DIR) $(1)/usr/bin
-	$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/xxd/xxd $(1)/usr/bin
-endef
-
-$(eval $(call BuildPackage,vim))
-$(eval $(call BuildPackage,vim-full))
-$(eval $(call BuildPackage,vim-runtime))
-$(eval $(call BuildPackage,vim-help))
-$(eval $(call BuildPackage,xxd))
-

file:a/utils/vim/files/vimrc (deleted)
--- a/utils/vim/files/vimrc
+++ /dev/null
@@ -1,13 +1,1 @@
-set showcmd		" show (partial) command in status line
-set showmatch		" show matching brackets
-set ignorecase		" do case insensitive matching
-set incsearch		" incremental search
-set autowrite		" automatically save before commands like :next and :make
-set nocompatible	" use vim defaults instead of 100% vi compatibility
-set backspace=indent,eol,start	" more powerful backspacing
-set autoindent		" always set autoindenting on
-set linebreak		" don't wrap words by default
-set textwidth=0		" don't wrap lines by default
-set ruler		" show the cursor position all the time
 
-

--- a/utils/vim/files/vimrc.full
+++ /dev/null
@@ -1,25 +1,1 @@
-set showcmd			" show (partial) command in status line
-set showmatch			" show matching brackets
-set ignorecase			" do case insensitive matching
-set incsearch			" incremental search
-set autowrite			" automatically save before commands like :next and :make
-set nocompatible		" use Vim defaults instead of 100% vi compatibility
-set backspace=indent,eol,start	" more powerful backspacing
-set autoindent			" always set autoindenting on
-set linebreak			" don't wrap words by default
-set textwidth=0			" don't wrap lines by default
-set ruler			" show the cursor position all the time
-if filereadable(expand("$VIMRUNTIME/syntax/synload.vim"))
-	syntax on
-endif
-if has("syntax") && &term =~ "xterm"
-	set t_Co=8
-	if has("terminfo")
-		set t_Sf=<Esc>[3%p1%dm
-		set t_Sb=<Esc>[4%p1%dm
-	else
-		set t_Sf=<Esc>[3%dm
-		set t_Sb=<Esc>[4%dm
-	endif
-endif
 

--- a/utils/vim/patches/001-cross_compile.patch
+++ /dev/null
@@ -1,39 +1,1 @@
---- a/src/auto/configure
-+++ b/src/auto/configure
-@@ -11641,34 +11641,8 @@ _ACEOF
- 
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking uint32_t is 32 bits" >&5
- $as_echo_n "checking uint32_t is 32 bits... " >&6; }
--if test "$cross_compiling" = yes; then :
--  as_fn_error "could not compile program using uint32_t." "$LINENO" 5
--else
--  cat confdefs.h - <<_ACEOF >conftest.$ac_ext
--/* end confdefs.h.  */
--
--#ifdef HAVE_STDINT_H
--# include <stdint.h>
--#endif
--#ifdef HAVE_INTTYPES_H
--# include <inttypes.h>
--#endif
--main() {
--  uint32_t nr1 = (uint32_t)-1;
--  uint32_t nr2 = (uint32_t)0xffffffffUL;
--  if (sizeof(uint32_t) != 4 || nr1 != 0xffffffffUL || nr2 + 1 != 0) exit(1);
--  exit(0);
--}
--_ACEOF
--if ac_fn_c_try_run "$LINENO"; then :
--  { $as_echo "$as_me:${as_lineno-$LINENO}: result: ok" >&5
-+  { $as_echo "$as_me:${as_lineno-$LINENO}: result: assuming ok" >&5
- $as_echo "ok" >&6; }
--else
--  as_fn_error "WRONG!  uint32_t not defined correctly." "$LINENO" 5
--fi
--rm -f core *.core core.conftest.* gmon.out bb.out conftest$ac_exeext \
--  conftest.$ac_objext conftest.beam conftest.$ac_ext
--fi
- 
- 
- 
 

comments