ksymoops: remove package, it has been obsolete and useless for a long time
[openwrt.org/packages.git] / libs / 100-do-not-use-librt.patch
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
--- a/tools/build/v2/tools/gcc.jam
+++ b/tools/build/v2/tools/gcc.jam
@@ -1063,8 +1063,7 @@ rule setup-threading ( targets * : sourc
             }
             case * :
             {
-                option = -pthread ;
-                libs = rt ;
+                # pass appropriate options via OpenWrt
             }
         }
     
--- a/tools/build/v2/tools/gcc.py
+++ b/tools/build/v2/tools/gcc.py
@@ -685,8 +685,8 @@ elif bjam.variable('UNIX'):
         # Darwin has no threading options, don't set anything here.
         pass
     else:
-        flags('gcc', 'OPTIONS', ['<threading>multi'], ['-pthread'])
-        flags('gcc', 'FINDLIBS-SA', [], ['rt'])
+        # pass appropriate options via OpenWrt
+        pass
 
 def cpu_flags(toolset, variable, architecture, instruction_set, values, default=None):
     #FIXME: for some reason this fails.  Probably out of date feature code
 
comments