eglibc: use version 2.19 by default (lots of fixes, some security related)
eglibc: use version 2.19 by default (lots of fixes, some security related)

Signed-off-by: Felix Fietkau <nbd@openwrt.org>

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39744 3c298f89-4303-0410-b956-a3cf2f4a3e73

--- a/toolchain/eglibc/Config.in
+++ b/toolchain/eglibc/Config.in
@@ -1,7 +1,7 @@
 choice
 	prompt "eglibc version"
 	depends on TOOLCHAINOPTS && USE_EGLIBC
-	default EGLIBC_USE_VERSION_2_15
+	default EGLIBC_USE_VERSION_2_19
 	help
 	  Select the version of eglibc you wish to use.
 

--- a/toolchain/eglibc/Config.version
+++ b/toolchain/eglibc/Config.version
@@ -6,10 +6,10 @@
 	default "2.19" if EGLIBC_VERSION_2_19
 
 config EGLIBC_VERSION_2_15
-	default y if !TOOLCHAINOPTS
 	bool
 
 config EGLIBC_VERSION_2_19
+	default y if !TOOLCHAINOPTS
 	bool
 
 endif

comments